1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Guest, PO has ceased our separate tiering and adopted Smogon tiers for SM. More information and updates here.

    Dismiss Notice

v2.6.2 Release

Discussion in 'News' started by Fuzzysqurl, Dec 8, 2015.

  1. Fuzzysqurl

    Fuzzysqurl baa baa mareep I do what I want Server Owner Developer I do what I want Server Owner Developer

    Joined:
    Sep 12, 2012
    Messages:
    2,096
    Likes Received:
    967
    Changelog:
    • Various crashes fixed (such as Primal Weather)
    • Updated some translations
    • Event moves for certain pokemon
    • Fixed a few images displaying incorrectly
    • Added a Damage Calculator to Teambuilder (still being refined, but its currently functional)
    • Flashes were fixed (woo) [Only for people who downloaded after 12/27]
    You can download it from Github here.

    Mac:
    https://github.com/jinorae/pokemon-online/releases/tag/2.6.2

    Android:
    Pick one:
    http://www.mediafire.com/download/cgv5s61vo91ov1e/android-client-debug.apk
    https://www.dropbox.com/s/lmwtxjnvcaxvji1/android-client-debug.apk?dl=0
     
    Last edited: May 10, 2016
  2. Email

    Email reformed xd

    Joined:
    Jan 27, 2014
    Messages:
    124
    Likes Received:
    135
    PO Trainer Name:
    Email
    Flash fix???
     
  3. Fuzzysqurl

    Fuzzysqurl baa baa mareep I do what I want Server Owner Developer I do what I want Server Owner Developer

    Joined:
    Sep 12, 2012
    Messages:
    2,096
    Likes Received:
    967
    Yeah hold on, let me just recode part of the Qt Framework to fix it.

    In other words, no.
     
  4. sulcata

    sulcata stéphane curry best waifu Forum Moderator Server Administrator Forum Moderator Server Administrator

    Joined:
    Jun 13, 2012
    Messages:
    968
    Likes Received:
    744
    The issue is that it's fixed in a more recent version of Qt (the framework PO is built on), so we'd need to convert some things in our code. That sounds simple, until you realize that we would need to switch scripting engines as Qt has deprecated the one currently in use.

    In other words, we can fix flashes, or we can risk breaking all client and server scripts. If someone wants to spend time going through and making sure each function works as intended, that would be great, but it's a long and arduous task.
     
  5. Fuzzysqurl

    Fuzzysqurl baa baa mareep I do what I want Server Owner Developer I do what I want Server Owner Developer

    Joined:
    Sep 12, 2012
    Messages:
    2,096
    Likes Received:
    967
    We could pop onto 5.1 or 5.2, which I think still keeps everything working EXCEPT the cancerous new battle window. This is the primary reason we didn't upgrade right as flashes got fixed. Our QtQuick for NBW is v1.2, which is deprecated in 5.1 in favor of QtQuick 2.0.

    I've tried a few times, got stuff partially working, but then ran out of things to change and it wasn't in a working condition.
     
  6. Lacus Clyne

    Lacus Clyne This might get unpleasant!

    Joined:
    Jan 19, 2014
    Messages:
    235
    Likes Received:
    383
    PO Trainer Name:
    Lacus Clyne
    why is defog on arc-fairy still not fixed???
     
  7. turbedi

    turbedi Professional circle clicker ~~~ Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jul 18, 2013
    Messages:
    385
    Likes Received:
    155
    PO Trainer Name:
    turbedi
    I will try to fix this on the weekend, I am too busy right now (or maybe someone else wants to fix it/ is able to fix it )
    @Fuzzysqurl ;)
     
  8. wfe

    wfe The Anima Is Watching...

    Joined:
    Nov 24, 2015
    Messages:
    9
    Likes Received:
    1
    PO Trainer Name:
    wfe
    ffs don't need to install since I used Qt editor 2 days ago to build a custom client anyways :v
     
  9. MidwayMarshall

    MidwayMarshall woof Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jun 13, 2014
    Messages:
    302
    Likes Received:
    167
    Qt is open source right? You wouldn't need to switch the entire engine but copy the source and customize it a little right? Happens all the time for android projects
     
  10. Duster

    Duster dodgerswin

    Joined:
    Sep 23, 2013
    Messages:
    377
    Likes Received:
    684
    turbedi and Draciel like this.
  11. mibuchiha

    mibuchiha Was yea ra chs ieeya.

    Joined:
    Oct 8, 2010
    Messages:
    1,313
    Likes Received:
    283
    PO Trainer Name:
    mibuchiha
    Someone update linux please :(
     
  12. Duster

    Duster dodgerswin

    Joined:
    Sep 23, 2013
    Messages:
    377
    Likes Received:
    684
  13. mibuchiha

    mibuchiha Was yea ra chs ieeya.

    Joined:
    Oct 8, 2010
    Messages:
    1,313
    Likes Received:
    283
    PO Trainer Name:
    mibuchiha
    Tried it, not working.

    [email protected] ~/Downloads/Files/pokemon-online-dist $ ./Pokemon-Online
    ./Pokemon-Online: error while loading shared libraries: libpng16.so.16: cannot open shared object file: No such file or directory

    Although I have the library already!

    output of sudo ldconfig -v:
    [...]
    /usr/local/lib:
    libpng16.so.16 -> libpng16.so.16.19.0
    [...]

    ---------------------------

    EDIT:

    Linking it directly through $LD_LIBRARY_PATH now gives this:

    ./Pokemon-Online: error while loading shared libraries: libpng16.so.16: wrong ELF class: ELFCLASS64
     
    Last edited: Dec 10, 2015
  14. Duster

    Duster dodgerswin

    Joined:
    Sep 23, 2013
    Messages:
    377
    Likes Received:
    684
    looks like you're running 64-bit linux
    that libpng is the 64-bit lib, which is why it won't be loaded by po

    i can try to put up a 64 bit version, but for now
    try doing apt-get install libpng:i386

    if that doesn't work, can you do ldd ./Pokemon-Online and post the output here?
     
  15. mibuchiha

    mibuchiha Was yea ra chs ieeya.

    Joined:
    Oct 8, 2010
    Messages:
    1,313
    Likes Received:
    283
    PO Trainer Name:
    mibuchiha
    Here ya go.

    [email protected] ~/Downloads/Files/pokemon-online-dist $ ldd ./Pokemon-Online
    ./Pokemon-Online: /usr/lib/i386-linux-gnu/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Core.so.5)
    ./Pokemon-Online: /lib/i386-linux-gnu/libdbus-1.so.3: no version information available (required by /home/ieeya/Downloads/Files/pokemon-online-dist/./libpulse.so.0)
    linux-gate.so.1 => (0xf76ff000)
    libpo-utilities.so.1 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libpo-utilities.so.1 (0xf76ad000)
    libpo-pokemoninfo.so.1 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libpo-pokemoninfo.so.1 (0xf762b000)
    libpo-battlemanager.so.1 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libpo-battlemanager.so.1 (0xf7557000)
    libpo-teambuilder.so.1 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libpo-teambuilder.so.1 (0xf7522000)
    libzip.so.4 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libzip.so.4 (0xf7508000)
    libQt5Declarative.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Declarative.so.5 (0xf714f000)
    libQt5Widgets.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Widgets.so.5 (0xf69fb000)
    libQt5Multimedia.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Multimedia.so.5 (0xf6902000)
    libQt5Gui.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Gui.so.5 (0xf6368000)
    libQt5Network.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Network.so.5 (0xf61df000)
    libQt5Xml.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Xml.so.5 (0xf619b000)
    libQt5Script.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Script.so.5 (0xf5ee8000)
    libQt5Core.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Core.so.5 (0xf5a16000)
    libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf59d2000)
    libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf58ea000)
    libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf58a4000)
    libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf5887000)
    libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf56d8000)
    libQt5OpenGL.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5OpenGL.so.5 (0xf5678000)
    libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf565e000)
    libQt5Sql.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5Sql.so.5 (0xf5613000)
    libQt5XmlPatterns.so.5 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libQt5XmlPatterns.so.5 (0xf5256000)
    libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0 (0xf5204000)
    libglib-2.0.so.0 => /lib/i386-linux-gnu/libglib-2.0.so.0 (0xf50f8000)
    libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf4fc4000)
    libpulse.so.0 => /home/ieeya/Downloads/Files/pokemon-online-dist/./libpulse.so.0 (0xf4f6a000)
    libpng16.so.16 => not found
    libharfbuzz.so.0 => /usr/lib/i386-linux-gnu/libharfbuzz.so.0 (0xf4f13000)
    libGL.so.1 => /usr/lib/i386-linux-gnu/mesa/libGL.so.1 (0xf4eb3000)
    libssl.so.1.0.0 => /lib/i386-linux-gnu/libssl.so.1.0.0 (0xf4e5b000)
    libcrypto.so.1.0.0 => /lib/i386-linux-gnu/libcrypto.so.1.0.0 (0xf4cae000)
    libicui18n.so.55 => not found
    libicuuc.so.55 => not found
    libpcre16.so.0 => not found
    libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf4ca8000)
    librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf4c9f000)
    /lib/ld-linux.so.2 (0xf7700000)
    libsystemd.so.0 => not found
    libffi.so.6 => /usr/lib/i386-linux-gnu/libffi.so.6 (0xf4c97000)
    libpcre.so.3 => /lib/i386-linux-gnu/libpcre.so.3 (0xf4c59000)
    libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf4c37000)
    libpulsecommon-7.0.so => not found
    libjson-c.so.2 => /lib/i386-linux-gnu/libjson-c.so.2 (0xf4c2b000)
    libdbus-1.so.3 => /lib/i386-linux-gnu/libdbus-1.so.3 (0xf4be0000)
    libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6 (0xf4b40000)
    libgraphite2.so.3 => /usr/lib/i386-linux-gnu/libgraphite2.so.3 (0xf4b24000)
    libglapi.so.0 => /usr/lib/i386-linux-gnu/libglapi.so.0 (0xf4b0c000)
    libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf4af8000)
    libXdamage.so.1 => /usr/lib/i386-linux-gnu/libXdamage.so.1 (0xf4af4000)
    libXfixes.so.3 => /usr/lib/i386-linux-gnu/libXfixes.so.3 (0xf4aee000)
    libX11-xcb.so.1 => /usr/lib/i386-linux-gnu/libX11-xcb.so.1 (0xf4aeb000)
    libxcb-glx.so.0 => /usr/lib/i386-linux-gnu/libxcb-glx.so.0 (0xf4ad3000)
    libxcb-dri2.so.0 => /usr/lib/i386-linux-gnu/libxcb-dri2.so.0 (0xf4acc000)
    libxcb-dri3.so.0 => /usr/lib/i386-linux-gnu/libxcb-dri3.so.0 (0xf4ac8000)
    libxcb-present.so.0 => /usr/lib/i386-linux-gnu/libxcb-present.so.0 (0xf4ac4000)
    libxcb-sync.so.1 => /usr/lib/i386-linux-gnu/libxcb-sync.so.1 (0xf4abd000)
    libxshmfence.so.1 => /usr/lib/i386-linux-gnu/libxshmfence.so.1 (0xf4aba000)
    libXxf86vm.so.1 => /usr/lib/i386-linux-gnu/libXxf86vm.so.1 (0xf4ab3000)
    libdrm.so.2 => /usr/lib/i386-linux-gnu/libdrm.so.2 (0xf4aa4000)
    libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf4aa0000)
    libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf4a99000)
    libpng12.so.0 => /lib/i386-linux-gnu/libpng12.so.0 (0xf4a71000)
     
  16. Duster

    Duster dodgerswin

    Joined:
    Sep 23, 2013
    Messages:
    377
    Likes Received:
    684
    i'll build a 64-bit version after i setup a new linux vm tonight
     
    mibuchiha likes this.
  17. Professor Oak

    Professor Oak same Forum Administrator Server Owner Social Media Rep Forum Administrator Server Owner Social Media Rep

    Joined:
    Apr 21, 2010
    Messages:
    3,557
    Likes Received:
    2,348
    PO Trainer Name:
    Professor Oak
    So I just went to install the newest version of PO, and it defaulted to saving into my Program Files folder, which has been known to cause some compatibility issues in the past.

    Could it be changed so that the newest release defaults to the user's folder as previous versions have done to prevent this issue for occurring?

    EDIT: Got confirmation from 2 other Windows users - it is defaulting to Program Files.
     
    Last edited: Dec 11, 2015
  18. turbedi

    turbedi Professional circle clicker ~~~ Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jul 18, 2013
    Messages:
    385
    Likes Received:
    155
    PO Trainer Name:
    turbedi
    I spent some time trying to fix some of these things and it looks like I was able to fix flashes ~
    @Professor Oak I also changed the default installation directory to C:\Users\<username>\Pokemon Online
    Here is the link.
    THIS IS A BETA! It is possible that this version causes crashes or some features don't work anymore. DON'T overwrite your old installation with this one.
    If you you have any problems with this version, PM me.

    Things that should be tested thoroughly in this version:
    - Flashes when a move is done
    - correct installation directory
    - New Battle Window
     
  19. Thugmon

    Thugmon Thugmon

    Joined:
    May 14, 2013
    Messages:
    15
    Likes Received:
    0
    PO Trainer Name:
    Thugmon
    linux please
     
  20. MidwayMarshall

    MidwayMarshall woof Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jun 13, 2014
    Messages:
    302
    Likes Received:
    167
  21. Lacus Clyne

    Lacus Clyne This might get unpleasant!

    Joined:
    Jan 19, 2014
    Messages:
    235
    Likes Received:
    383
    PO Trainer Name:
    Lacus Clyne
    is arc-fairy getting fixed next update or is it already?
     
  22. turbedi

    turbedi Professional circle clicker ~~~ Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jul 18, 2013
    Messages:
    385
    Likes Received:
    155
    PO Trainer Name:
    turbedi
    It isn't fixed yet, because I spent most of the time trying to fix flashes. I think I know how to fix Arceus-Fairy, but I cannot tell when we will release the fix; probably once the new beta client is tested thoroughly and there aren't any problems with it.
     
  23. mibuchiha

    mibuchiha Was yea ra chs ieeya.

    Joined:
    Oct 8, 2010
    Messages:
    1,313
    Likes Received:
    283
    PO Trainer Name:
    mibuchiha
    64-bit linux DL link still empty; not built yet or oversight?
     
  24. Professor Oak

    Professor Oak same Forum Administrator Server Owner Social Media Rep Forum Administrator Server Owner Social Media Rep

    Joined:
    Apr 21, 2010
    Messages:
    3,557
    Likes Received:
    2,348
    PO Trainer Name:
    Professor Oak
    I never got given the link to update. I'll have a quick look.
     
  25. Duster

    Duster dodgerswin

    Joined:
    Sep 23, 2013
    Messages:
    377
    Likes Received:
    684
  26. mibuchiha

    mibuchiha Was yea ra chs ieeya.

    Joined:
    Oct 8, 2010
    Messages:
    1,313
    Likes Received:
    283
    PO Trainer Name:
    mibuchiha
    Not working @Duster.

    ./Pokemon-Online: error while loading shared libraries: libpulsecommon-7.1.so: cannot open shared object file: No such file or directory
     
  27. Duster

    Duster dodgerswin

    Joined:
    Sep 23, 2013
    Messages:
    377
    Likes Received:
    684
    try apt-get install libpulse0

    also, could you pm me the output of ldd again
     
  28. Purpleseamonkey

    Purpleseamonkey PO Alt: y0

    Joined:
    Feb 11, 2012
    Messages:
    220
    Likes Received:
    72
    PO Trainer Name:
    y0 , y01, y02 , y03
  29. mibuchiha

    mibuchiha Was yea ra chs ieeya.

    Joined:
    Oct 8, 2010
    Messages:
    1,313
    Likes Received:
    283
    PO Trainer Name:
    mibuchiha
    @Duster

    Reading state information... Done
    libpulse0 is already the newest version.

    [email protected] ~/Downloads/Files/po-dist64 $ ldd ./Pokemon-Online
    ./Pokemon-Online: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./Pokemon-Online)
    ./Pokemon-Online: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/ieeya/Downloads/Files/po-dist64/./libpo-utilities.so.1)
    ./Pokemon-Online: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/ieeya/Downloads/Files/po-dist64/./libpo-pokemoninfo.so.1)
    ./Pokemon-Online: /lib/x86_64-linux-gnu/libdbus-1.so.3: no version information available (required by /home/ieeya/Downloads/Files/po-dist64/./libpulse.so.0)
    linux-vdso.so.1 => (0x00007fffe6ffe000)
    libpo-utilities.so.1 => /home/ieeya/Downloads/Files/po-dist64/./libpo-utilities.so.1 (0x00007f09ab45b000)
    libpo-pokemoninfo.so.1 => /home/ieeya/Downloads/Files/po-dist64/./libpo-pokemoninfo.so.1 (0x00007f09ab1da000)
    libpo-battlemanager.so.1 => /home/ieeya/Downloads/Files/po-dist64/./libpo-battlemanager.so.1 (0x00007f09aaeeb000)
    libpo-teambuilder.so.1 => /home/ieeya/Downloads/Files/po-dist64/./libpo-teambuilder.so.1 (0x00007f09aacb0000)
    libzip.so.4 => /home/ieeya/Downloads/Files/po-dist64/./libzip.so.4 (0x00007f09aaa9b000)
    libQt5OpenGL.so.5 => /usr/lib/x86_64-linux-gnu/libQt5OpenGL.so.5 (0x00007f09aa80f000)
    libQt5Declarative.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Declarative.so.5 (0x00007f09aa296000)
    libQt5Multimedia.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Multimedia.so.5 (0x00007f09a9fbc000)
    libQt5Widgets.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5 (0x00007f09a9793000)
    libQt5Concurrent.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Concurrent.so.5 (0x00007f09a958d000)
    libQt5Script.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Script.so.5 (0x00007f09a910d000)
    libQt5Xml.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Xml.so.5 (0x00007f09a8ed1000)
    libQt5Network.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Network.so.5 (0x00007f09a8b8d000)
    libQt5Gui.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5 (0x00007f09a853f000)
    libQt5Core.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 (0x00007f09a7e99000)
    libGL.so.1 => /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1 (0x00007f09a7c33000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f09a7a14000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f09a7710000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f09a740a000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f09a71f3000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f09a6e2e000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f09a6c14000)
    libQt5Sql.so.5 => /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5 (0x00007f09a69d5000)
    libpulse.so.0 => /home/ieeya/Downloads/Files/po-dist64/./libpulse.so.0 (0x00007f09a6783000)
    libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f09a6532000)
    libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f09a622a000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f09a5ef5000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f09a5cec000)
    libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f09a5ac6000)
    libharfbuzz.so.0 => /usr/lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f09a5870000)
    libicui18n.so.52 => /usr/lib/x86_64-linux-gnu/libicui18n.so.52 (0x00007f09a5469000)
    libicuuc.so.52 => /usr/lib/x86_64-linux-gnu/libicuuc.so.52 (0x00007f09a50f0000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f09a4eeb000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f09ab6b7000)
    libglapi.so.0 => /usr/lib/x86_64-linux-gnu/libglapi.so.0 (0x00007f09a4cc4000)
    libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f09a4ab2000)
    libXdamage.so.1 => /usr/lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f09a48ae000)
    libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f09a46a8000)
    libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007f09a44a6000)
    libxcb-glx.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-glx.so.0 (0x00007f09a428e000)
    libxcb-dri2.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri2.so.0 (0x00007f09a4089000)
    libxcb-dri3.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-dri3.so.0 (0x00007f09a3e86000)
    libxcb-present.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-present.so.0 (0x00007f09a3c82000)
    libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007f09a3a7c000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f09a385d000)
    libxshmfence.so.1 => /usr/lib/x86_64-linux-gnu/libxshmfence.so.1 (0x00007f09a365a000)
    libXxf86vm.so.1 => /usr/lib/x86_64-linux-gnu/libXxf86vm.so.1 (0x00007f09a3454000)
    libdrm.so.2 => /usr/lib/x86_64-linux-gnu/libdrm.so.2 (0x00007f09a3247000)
    libpulsecommon-7.1.so => not found
    libjson-c.so.2 => /lib/x86_64-linux-gnu/libjson-c.so.2 (0x00007f09a303b000)
    libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f09a2df5000)
    libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f09a2bed000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f09a29af000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f09a270b000)
    libgraphite2.so.3 => /usr/lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f09a24ef000)
    libicudata.so.52 => /usr/lib/x86_64-linux-gnu/libicudata.so.52 (0x00007f09a0c81000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f09a0a7d000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f09a0876000)
     
  30. Duster

    Duster dodgerswin

    Joined:
    Sep 23, 2013
    Messages:
    377
    Likes Received:
    684
  31. mibuchiha

    mibuchiha Was yea ra chs ieeya.

    Joined:
    Oct 8, 2010
    Messages:
    1,313
    Likes Received:
    283
    PO Trainer Name:
    mibuchiha
    Nope:

    ./Pokemon-Online: error while loading shared libraries: libsystemd.so.0: cannot open shared object file: No such file or directory

    @Duster

    Btw testing an 2.4.1 on Ubuntu I got this funny error:

    appmenu-qt: handleReparent 133 The given QMenuBar is already registered by appmenu-qt5, skipping

    Might want to look into this too.
     
    Last edited: Dec 20, 2015
  32. turbedi

    turbedi Professional circle clicker ~~~ Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jul 18, 2013
    Messages:
    385
    Likes Received:
    155
    PO Trainer Name:
    turbedi
    Update
    I released the beta client officially which has WORKING FLASHES (woooo) and I also fixed some other (minor) bugs.
    If you have downloaded the client before the 27th December, redownload it to have working flashes. :)
     
    Roshi, Purpleseamonkey and sulcata like this.
  33. Darth Magnus

    Darth Magnus Eaten Back To Life

    Joined:
    Nov 6, 2014
    Messages:
    25
    Likes Received:
    5
    PO Trainer Name:
    [HH]Magnus
    Ever since the update, the battle window is blank. No environment, no mons, nothing. I didn't change any settings from before, either. What's wrong?
     
  34. turbedi

    turbedi Professional circle clicker ~~~ Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jul 18, 2013
    Messages:
    385
    Likes Received:
    155
    PO Trainer Name:
    turbedi
    Try toggling Battle Options -> Old battle window.
    You are using Windows, right?
     
  35. Darth Magnus

    Darth Magnus Eaten Back To Life

    Joined:
    Nov 6, 2014
    Messages:
    25
    Likes Received:
    5
    PO Trainer Name:
    [HH]Magnus
    Yeah, the old battle window works, but it looks like garbage compared to the new one. I did all the toggles and everything that normally needs to be done, and it still doesn't work.
     
  36. 海森堡

    海森堡 New Member

    Joined:
    Apr 18, 2014
    Messages:
    5
    Likes Received:
    0
    I have to disable the pokmon cries for normal playing....
    anyway to keep the game playable and enable the cries?:smile:
     
  37. Pumone

    Pumone Member

    Joined:
    Aug 30, 2015
    Messages:
    57
    Likes Received:
    11
    With 2.6.1 I used to play against myself to test damages (I prefer this way than the damage calculator), but when I updated to 2.6.2 I can't do this, Pokemon in the second window are not displayed and can do nothing. So can anyone fix this?

    Also I would love to see a random battle like the one in Pokemon Showdown where pokemon are randomly generated but with VIABLE moveset and not fully random, it's not a good thing to play with a Salamence with Tackle, Bite...

    So I think Challenge Cup may be more like "Random Battle" with more realistic movesets.
     
  38. turbedi

    turbedi Professional circle clicker ~~~ Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jul 18, 2013
    Messages:
    385
    Likes Received:
    155
    PO Trainer Name:
    turbedi
    Do you use New Battle Window? If yes, turn it off and try again.
     
  39. Pumone

    Pumone Member

    Joined:
    Aug 30, 2015
    Messages:
    57
    Likes Received:
    11
    I tried all kind of options, new and old battle window, 3d animated models or simple static, it doesn't matter what I do, still doesn't work for me. Thank you anyway.
     
  40. turbedi

    turbedi Professional circle clicker ~~~ Forum Moderator Developer Forum Moderator Developer

    Joined:
    Jul 18, 2013
    Messages:
    385
    Likes Received:
    155
    PO Trainer Name:
    turbedi
    Did you also try disabling Pokemon Cries and Battle Music?
     
    Pumone likes this.